Blog by Markus Müller

Mein Lifestyle, meine Hobbies und alles dazwischen.

Wochenrückblick 15. Juli 2010

Mein letzter Post ist ja nun schon 6 Tage her. Mittlerweile hat sich einiges getan. Daher schreibe ich jetzt eine kleine Zusammenfassung der Ereignisse.

Gartenarbeit und das Carport

Diese Woche war ich nochmal im Garten am werkeln. Wir haben für unser doch schon etwas herunter gekommenes Carport neue Bretter für eine Überdachung bestellt. Zunächst hab ich das ganze Gestrüpp und die Büche entfernt. Dann hab ich geholfen die Bretter zu befestigen. 

Schwimmen fällt ins Wasser

In den letzten Wochen hatte ich verdammt wenig Zeit und konnte daher nicht zum Schwimmen gehen. Dieses Unregelmäßige bringt aber leider gar nichts. Diese Woche wollte ich dann nochmal hin aber in der Sommerzeit haben die meisten Hallenbäder geschlossen. Wegen der Arbeit habe ich ja auch nur abends Zeit und dann will man ja auch nicht noch ins Freibad gehen. Zudem denke ich auch, dass Freibäder für den Zweck Bahnen zu schwimmen ungeeignet sind. Meist tummeln sich in Freibändern einfach zu viele Leute die da einfach nur Spaß und Abkühlung wollen. Naja nun muss ich mich erstmal nach einer Alternative umsehen.

Acronis Backup

Gestern sollte ich eine Übertragung eines Windows 7 Systems durchführen von einer SATA Laptop Festplatte auf eine neue SSD Festplatte. Es handelt sich dabei um einen Lenovo Laptop. Auf der Festplatte waren 3 Partitionen, darunter Laufwerk C: mit Windows, eine Service Partition und eine Datenpartition. Die SSD Platte hatte aber nur 64 also entschieden wir uns dafür nur den MBR und die Windows Partition zu sichern. Dazu habe ich meine Acronis Home 2010 Boot CD genutzt. Ich erstellte also ein Image der besagten Partitionen auf ein Netzwerkspeicher und habe im nächsten Schritt ein Recovery auf die SSD Platte gestartet. Nach der Sicherung  trat direkt der erste Fehler auf. Bootmgr nicht gefunden. Mittels Win 7 CD habe ich den Fehler dann beseitigt und Windows ist hoch gefahren. Leider musst ich feststelle, dass sich der Laufwerksbuchstabe von C: in G: geändert hat. Wie dies zustande kommt, weis ich bis heute nicht. Versuche mittels Diskpart den Buchstaben zu ändern schlugen fehl.

Dann startete ich den zweiten Versuch und habe ein Image der gesamten Disc erstellt. Dazu habe ich aber nicht die Home Version genutzt sondern die Backup and Recovery for Server Boot CD. Nach dem Recoveryvorgang fuhr Windows mit der SSD Festplatte einwandfrei hoch. Kein Bootmgr Fehler, so wie es sein soll. In der Festplattenverwaltung bemerkte ich dann, dass die Servicepartition von Lenovo die aktive Systempartition ist. Windows 7 ist aber das Laufwerk C: Durch diese Konstelation wurde mir klar warum der erste Veruch gescheitert ist. Die MBR Informationen und der Bootmgr stehen alle in der Service Partition und müssen daher mit kopiert werden.

Die Datenpartition habe ich mittels Festplattenverwaltung unter Windows gelöscht und haben den freien Speicher der Windowspartition zugewisen. Das hat alles wunderbar geklappt. Damit die lästige Servicepartition nicht im Arbeitsplatz angezeigt wird, habe ich den Laufwerksbuchstaben gelöscht. Die Partition besteht aber weiterhin und ist für den Bootvorgang wichtig.
 
Sharepoint mit Windows 7
Derzeit setze ich immer mehr auf Sharepoint für meine Dokumentenverwaltung. Mittlerweile habe ich fast alle meine Dokumente von der Festplatte im Sharepoint gespeichert und bearbeite diese auch dort. Mit meinem Laptop unter XP klappt das ganze auch einwandfrei. Oft arbeite ich mit dem Laptop von unterwegs an den Daten. Nun habe ich aber auf meinem Heimarbeitsplatz Windows 7 und in letzter Zeit muss ich auch von dort immer mehr Daten bearbeiten. 

Nun gibt es unter Win7 die Eigenart, dass Zugriffe auf Dateien ungewöhnlich lange dauern. Beim öffnen von Dokumenten oder bei der Verwendung der Explorer Ansicht kommt es zu unglaublichen Wartezeiten bis Word oder Excel die Verbindung zu dem Server aufgebaut hat. Das ärgerte mich natürlich schon sehr, da ich mit dem Laptop und XP wesentlich schneller arbeiten konnte als mit dem gut ausgestatteten Desktop PC. Also fragte ich bei google um Rat. Dieser wollte mir aber zunächst nicht so richtig weiter helfen. Nach vielen Umstellungen meines Suchbegriffes bin ich dann doch auf eine Lösung gestoßen.

Lösung: Man muss die automatische Suche der Proxyeinstellung deaktivieren. Internetoptionen -> Verbindung -> Lan Einstellungen.

Seither klappt alles wunderbar und ich kann endlich auch am PC flüssig arbeiten.

OWA, Zertifikate und Externer Zugriff

Neben Sharepoint greife ich noch von Extern auf meinen Outlook Account zu. Dieser ist erreichbar über eine gesicherte SSL Leitung via HTTPS. Diese Verbindungen erfordern ein Zugriffszertifikat und dieses ist meist ausgestellt für den Zugriff via internem LAN. Will man die Seite aber nun über eine externe URL aufrufen, erhält man zunächst einen Zertifikatsfehler. Diesen kann man aber übergehen und kann dann arbeiten. Um diesen Fehler zu beseitigen muss man ein Zertifikat am Server ausstellen der auf den Namen der externen URL lautet.

Über viele Artikel im Internet habe ich mich in diese Materie eingelesen und habe herausgefunden, wie man ein solches Zertifikat erstellt und am Client einspielt. Für meine URL team.futuresight.de habe ich dann ein solches Zertifikat erstellt. Im IIS habe ich dann am Server unter der OWA Seite dieses Zertifikat angegeben für den Zugriff via SSL. Als nächstes habe ich das Zertifikat exportiert und via Stick auf dem Laptop importiert. Danach ging die OWA Seite ohne den Zertifikatfehler auf.

Beim Arbeiten mit Outlook stellte sich aber schon das nächste Problem ein. Outlook scheint auch über diese Verbindung Daten mit dem Exchange auszutauschen. Outlook geht aber über LAN und daher ist das Zertifikat für das LAN erforderlich. Leider kann man für die SSL Verbindung immer nur ein Zertifikat angeben. Im Internet las ich wie man über Commandozeile ein Zertifikat ausstellen kann, das auf mehrere Domain Names läuft. Leider hat die Vorgehensweise nicht so funktioniert wie beschrieben und ich muss weiter suchen. Leider bietet auch das Internet zu solch speziellen Fällen nicht immer eine Lösung.

SSD endlich da
JCE Editor

Ähnliche Beiträge

 

Kommentare

Keine Kommentare vorhanden
Bereits registriert? Hier einloggen
Gäste
Dienstag, 21. November 2017
If you'd like to register, please fill in the username, password and name fields.